You must be logged in to post messages.
Please login or register

Scenario Design and Discussion
Moderated by Sebastien, Mr Wednesday

Hop to:    
Welcome! You are not logged in. Please Login or Register.10 replies
Age of Kings Heaven » Forums » Scenario Design and Discussion » Ugh.. Crashing
Bottom
Topic Subject:Ugh.. Crashing
Mr Unknown
Squire
posted 04-30-06 06:35 PM CT (US)         
Sorry for not reading the FAQ page, I tried but it doesn't open the page...
My game crashed right on a trigger where I placed it that you get 10 damage by going nearyby a rock like this:

Trigger0: Starting State on, Display as objective: off Looping off.
----
Condition0: Bring object to area. (The character I chose
and beside rock)

Trigger0: Display instructions: -You've been hit by falling rocks!- Inflicted 10 damage

Trigger1: Damage Object: 10, and I set object and area.

========================================================

My game keeps crashing now.. Is there a wayto stop it?
I think I remember copieing and pasting from the FAQs guide.

[This message has been edited by Mr Unknown (edited 04-30-2006 @ 06:35 PM).]

AuthorReplies:
steffenlaursen
Squire
posted 04-30-06 06:42 PM CT (US)     1 / 10       
Try not selecting the unit, but only the area...

Or try using "objects in area" instead of "Bring object to area".

Don't know if it helps.


Current project: King Wilhelm <-I added screenshots

[This message has been edited by steffenlaursen (edited 04-30-2006 @ 06:44 PM).]

zyxomma100
Squire
posted 04-30-06 06:49 PM CT (US)     2 / 10       
He is using an area. And I think that's his problem.

When setting an area, you must click "Go to Area" afterward, or else it won't work. The trigger will then try to affect all units on the map, crashing the game.

Make sure you have the player set, also.


zyxomma100- Age of Kings Heaven forumer
Proudly thwarting Dark_Aro's evil plans since 2002
"There is nothing more sad than watching a teutonic knight chasing a petard."
newIdea
Illuminator
posted 04-30-06 07:05 PM CT (US)     3 / 10       
Si. Make sure your damage effect isn't on Gaia, or it is likely to crash. That's what it sounds like...



dannyking.me


zyxomma100
Squire
posted 04-30-06 07:08 PM CT (US)     4 / 10       
Eh... I'm betting that the problem was not hitting Go to Area.

Small bet of... say, 100 cookies?


zyxomma100- Age of Kings Heaven forumer
Proudly thwarting Dark_Aro's evil plans since 2002
"There is nothing more sad than watching a teutonic knight chasing a petard."
newIdea
Illuminator
posted 04-30-06 07:10 PM CT (US)     5 / 10       
You're on. But, you keep track of cookies.



dannyking.me


[This message has been edited by newIdea (edited 04-30-2006 @ 07:16 PM).]

Mr Unknown
Squire
posted 04-30-06 07:38 PM CT (US)     6 / 10       
Haha! Looks like newIdea is going to be winning those cookies!
It worked, I needed to set it to Player 1, not Gaia.
zyxomma100
Squire
posted 04-30-06 07:47 PM CT (US)     7 / 10       
Damn.

*starts baking*


zyxomma100- Age of Kings Heaven forumer
Proudly thwarting Dark_Aro's evil plans since 2002
"There is nothing more sad than watching a teutonic knight chasing a petard."
Mr Unknown
Squire
posted 05-10-06 05:17 PM CT (US)     8 / 10       
I made this scenario so that there is a spearman blocking the road (player2). I have these knights (player3) come up to the spearman, so i tasked it so that when you bring the knight to the spearman, the spearman moves away.
Its like this

Trigger0
Starting on
loopin off
display objective off

Condition0:Bring object to object(Knight 1 to spearman)
condition1:Bring object to object(Knight 2 to spearman)
Effect0:task object(backs up)
Effect1:Activate Trigger: 1

Trigger1
starting off
loopin off
display objective off

Condition0:Timer(8)
Effect0:Task object(Back to original spot)

When I play the game, I used the marco/polo to see if the
knights would go up to the spearman and then see if he would move but the game crahsed. Helpity help!


Daftpanzer
Squire
posted 05-10-06 05:49 PM CT (US)     9 / 10       
BTW, about the 'go to area' method... Ive always found that as long as you set the location first, and then set area afterwards, it will work just fine... i dont seem to need to click 'go to area'.

Basically, i think that setting the location usually removes the area setting, so i always re-set the area if ive changed the location, and this seems to work for me...

[This message has been edited by Daftpanzer (edited 05-10-2006 @ 05:50 PM).]

Mr Unknown
Squire
posted 05-10-06 05:53 PM CT (US)     10 / 10       
But that doesn't solve my problem.

[This message has been edited by Mr Unknown (edited 05-10-2006 @ 05:57 PM).]

You must be logged in to post messages.
Please login or register

Hop to:    

Age of Kings Heaven | HeavenGames