You must be logged in to post messages.
Please login or register

Mod Design and Discussion
Moderated by Mr Wednesday, John the Late

Hop to:    
Welcome! You are not logged in. Please Login or Register.No replies
Age of Kings Heaven » Forums » Mod Design and Discussion » UP effect_amount not working?
Bottom
Topic Subject:UP effect_amount not working?
nhoobish_est
Squire
posted 07-21-19 12:02 PM CT (US)         
So I tried RM scripting and wanted to do some cool units, but seemingly got stuck as to best of my efforts by trying different versions and searching up answers online nothing interesting happened.

<PLAYER_SETUP>
random_placement
effect_amount SET_ATTRIBUTE VILLAGER_CLASS ATTR_HITPOINTS 100
effect_amount SET_ATTRIBUTE ALEXANDER_NEVSKI ATTR_HITPOINTS 1000

I defined the #const at the top.
Looked up UserPatch/Reference/Scripting/Reference.html# for exact code.
Tried the AzureFalls.rms that comes as an example.
And still none of the effect_amount commands go through.
What gibs?
What am I doing so wrong that not even the default example map does not work?
Or is it really not working?
I am confused and upset.

Edit: Sorry, made the thread in the wrong place, my bad, brain stopped working sometime today.

Edit: Figured out my weird problem, none of the effect_amount commands work when generating a random map in the scenario editor and using it to test. Obviously since I am testing a scenario. Noob alert!

Mods can delete this god-awful miserable thread or maybe just move it to the proper sub-forum?

[This message has been edited by nhoobish_est (edited 07-22-2019 @ 01:26 PM).]

You must be logged in to post messages.
Please login or register

Hop to:    

Age of Kings Heaven | HeavenGames