You must be logged in to post messages.
Please login or register

The University

Hop to:    
Topic Subject: Adding civilizations to AoE2 (Approved)
« Previous Page  1 2  Next Page »
posted 10-01-12 04:22 PM CT (US)   
This article has been approved and can now be read in The University -Felix36

This is all possible because of UserPatch by xOmicron, and you need the latest UserPatch for this to work.

Preliminary Steps

First, you need to download and install UserPatch. Then, go to the folder where AoE2:TC is installed. Create a folder called Games. When you unpacked UserPatch, a folder called Reference should have been created. Go into this folder. There should be a file called age2_x1.xml. Copy this file to your Games folder that you just created.

The XML File

Now edit (using any simple text editor) the age2_x1.xml that you just copied and pasted. It should look something like this:

<?xml version="1.0" encoding="utf-8"?>
<configuration game="age2_x1">
<name>Age of Empires II: The Conquerors Expansion 2</name>
<path>The Conquerors</path>
<civilizations langId="10230" descId="20150" aiNameOffset="140" uiBaseId="51100" uiStride="20" uiOffset="2">
<civilization id="0" name="gaia" soundFile="stream\random.mp3" scoutUnit="448" uniqueUnit="0" eliteUniqueUnit="0" uniqueUnitLine="0" uniqueUnitUpgrade="0" uniqueResearch="0" />
<civilization id="2" name="briton" soundFile="stream\british.mp3" scoutUnit="448" uniqueUnit="8" eliteUniqueUnit="530" uniqueUnitLine="-277" uniqueUnitUpgrade="360" uniqueResearch="3" />
<civilization id="6" name="frankish" soundFile="stream\french.mp3" scoutUnit="448" uniqueUnit="281" eliteUniqueUnit="531" uniqueUnitLine="-272" uniqueUnitUpgrade="363" uniqueResearch="83" />
<civilization id="7" name="gothic" soundFile="stream\goth.mp3" scoutUnit="448" uniqueUnit="41" eliteUniqueUnit="555" uniqueUnitLine="-279" uniqueUnitUpgrade="365" uniqueResearch="16" />
<civilization id="16" name="teutonic" soundFile="stream\teuton.mp3" scoutUnit="448" uniqueUnit="25" eliteUniqueUnit="554" uniqueUnitLine="-273" uniqueUnitUpgrade="364" uniqueResearch="11" />
<civilization id="9" name="japanese" soundFile="stream\japanese.mp3" scoutUnit="448" uniqueUnit="291" eliteUniqueUnit="560" uniqueUnitLine="-274" uniqueUnitUpgrade="366" uniqueResearch="59" />
<civilization id="5" name="chinese" soundFile="stream\chinese.mp3" scoutUnit="448" uniqueUnit="73" eliteUniqueUnit="559" uniqueUnitLine="-280" uniqueUnitUpgrade="362" uniqueResearch="52" />
<civilization id="3" name="byzantine" soundFile="stream\byzantin.mp3" scoutUnit="448" uniqueUnit="40" eliteUniqueUnit="553" uniqueUnitLine="-281" uniqueUnitUpgrade="361" uniqueResearch="61" />
<civilization id="13" name="persian" soundFile="stream\persian.mp3" scoutUnit="448" uniqueUnit="239" eliteUniqueUnit="558" uniqueUnitLine="-271" uniqueUnitUpgrade="367" uniqueResearch="7" />
<civilization id="14" name="saracen" soundFile="stream\saracen.mp3" scoutUnit="448" uniqueUnit="282" eliteUniqueUnit="556" uniqueUnitLine="-276" uniqueUnitUpgrade="368" uniqueResearch="9" />
<civilization id="17" name="turkish" soundFile="stream\turk.mp3" scoutUnit="448" uniqueUnit="46" eliteUniqueUnit="557" uniqueUnitLine="-278" uniqueUnitUpgrade="369" uniqueResearch="10" />
<civilization id="18" name="viking" soundFile="stream\viking.mp3" scoutUnit="448" uniqueUnit="692" eliteUniqueUnit="694" uniqueUnitLine="-282" uniqueUnitUpgrade="398" uniqueResearch="49" />
<civilization id="12" name="mongol" soundFile="stream\mongol.mp3" scoutUnit="448" uniqueUnit="11" eliteUniqueUnit="561" uniqueUnitLine="-275" uniqueUnitUpgrade="371" uniqueResearch="6" />
<civilization id="4" name="celtic" soundFile="stream\celt.mp3" scoutUnit="448" uniqueUnit="232" eliteUniqueUnit="534" uniqueUnitLine="-269" uniqueUnitUpgrade="370" uniqueResearch="5" />
<civilization id="15" name="spanish" soundFile="stream\spanish.mp3" scoutUnit="448" uniqueUnit="771" eliteUniqueUnit="773" uniqueUnitLine="-264" uniqueUnitUpgrade="60" uniqueResearch="440" />
<civilization id="1" name="aztec" soundFile="stream\aztecs.mp3" scoutUnit="751" uniqueUnit="725" eliteUniqueUnit="726" uniqueUnitLine="-268" uniqueUnitUpgrade="432" uniqueResearch="24" />
<civilization id="11" name="mayan" soundFile="stream\mayans.mp3" scoutUnit="751" uniqueUnit="763" eliteUniqueUnit="765" uniqueUnitLine="-266" uniqueUnitUpgrade="27" uniqueResearch="4" />
<civilization id="8" name="hun" soundFile="stream\huns.mp3" scoutUnit="448" uniqueUnit="755" eliteUniqueUnit="757" uniqueUnitLine="-265" uniqueUnitUpgrade="2" uniqueResearch="21" />
<civilization id="10" name="korean" soundFile="stream\koreans.mp3" scoutUnit="448" uniqueUnit="827" eliteUniqueUnit="829" uniqueUnitLine="-270" uniqueUnitUpgrade="450" uniqueResearch="445" />

The Tags

<configuration>: The @game attribute specifies the game ID. The AIs use this "#if-defined GAME-@game" to load certain effects. Only useful if you want an AI to be used for more than one expansion.
<name>: Changing this is not known to do anything.
<path>: Specifies the folder within the Games folder where future saved and recorded games, scenarios, random map scripts, and AI scripts should be stored. A folder corresponding to this tag's value will be created when you start the game.
<civilizations>: @langId specifies the language_x1.dll name of the first civilization. @descId specifies the first language_x1.dll civilization description. @aiNameOffset has to do with the AI character names for civilizations. @uiBaseId specifies the first civilization UI slp in interfac.drs. @uiStride specifies the total number of civ UIs. This should be equal to the total number of civilizations. @uiOffset specifies the gap between the last UI of one resolution and the first UI of the next largest resolution.

Adding Civilizations

Finally! The <civilization> tag denotes a civilization. Add another of these tags to the list, and you've added a civilization. Now, lets get down to the attributes:

@id: The id number of a civilization. This number specifies the order of the UIs slps, and it is important for the data and language files. Each civ should have its own unique id. Your first new civ should have an id of 19.
@name: The internal name of a civilization.
@soundFile: The sound file that plays when a civilization is picked in a random map game.
@scoutUnit: The starting scout unit id (from the data files) of a civilization. Scout Cavalry is #448.
@uniqueUnit: The id number of the unique unit of a civilization.
@eliteUniqueUnit: The id number of the elite unique unit of a civilization.
@uniqueUnitLine: The unit line of the unique unit. The editing of unit lines has not been fully discovered.
@uniqueUnitUpgrade: The research that upgrades the unique unit to elite status.
@uniqueResearch: The unique research of a civilization.

Once you've added and edited all the <civilization> lines you want, save the xml file and start the game. Your new civilizations will be automatically added to the data file and will automatically appear in game.

Not Done Yet

I guess you could technically be done now. But, unless you want your new civs to be awful, you need to do more. Use Advanced Genie Editor 2 for data editing, Turtle Pack for graphics, and XN Resource Editor for language dll editing. With that, you're set!

P.S.: This article is correct as far as I know. However, this was all deduced by trial and error before UserPatch came with a readme that explains adding civs. Now that UserPatch does have such a readme, it makes this tutorial somewhat outdated. Scripter64 and Cysion know much more about this than I do.

[This message has been edited by LmScar13 (edited 01-28-2013 @ 10:05 AM).]

posted 10-02-12 03:03 AM CT (US)     1 / 97  
Ah... right. This article seems good, but we have a bit of a grey area surrounding the UserPatch in HG policy at the moment. I'm going to need to raise this with some higher-ups so for the moment, I've removed the link from your article. Whatever happens, you're not in trouble, it's just that if we add this to The University we may be seen to be endorsing the UserPatch which I'm not sure HG wants to do.
posted 10-02-12 03:30 AM CT (US)     2 / 97  
Is UserPatch illegal in some countries?

Advanced Genie Editor
Follow coding here and here.
posted 10-02-12 03:34 AM CT (US)     3 / 97  
Isn't there issues surrounding it doing something to the .exe?

I could have dreamed that, mind you. I wouldn't put it past me...
posted 10-02-12 04:15 AM CT (US)     4 / 97  
What's the difference between modding the executable or other files.

Advanced Genie Editor
Follow coding here and here.
posted 10-02-12 05:24 AM CT (US)     5 / 97  
HG policy.
posted 10-02-12 10:07 AM CT (US)     6 / 97  
I thought HG had already discussed this... HG's policy is from like 1997
posted 10-02-12 10:11 AM CT (US)     7 / 97  
HG is currently discussing this issue. I believe HG policy is still no .exe cracking of any kind, but in light of the UserPatch: this may be over-turned. I'm still waiting for this issue to end up on the appropriate forum-desks.
posted 10-02-12 01:02 PM CT (US)     8 / 97  
The Userpatch does not contain an .exe file in the download. Instead, it edits a preexisting .exe file, and I believe it checks to make sure that the user has a legal version installed on their computer. No one can install it on their computer unless they have purchased the game first before it will installed. That's what makes it different from a crack. HG's lawyer has said the Userpatch was okay for these reasons.
This article is in the clear. As is all future discussion of the UserPatch.

Also, I am happy to approve this article as it stands right now. I'll likely add some links to other articles in the final section when it is set in stone in our hallowed halls, if no-one objects. In the meantime though, consider this approved and winging its way to an AoKH University near you shortly.

[This message has been edited by Felix36 (edited 10-02-2012 @ 01:05 PM).]

posted 10-02-12 02:15 PM CT (US)     9 / 97  
Thanks for the fast-track, Felix.

Hopefully the article will be useful for modders.
posted 10-02-12 05:30 PM CT (US)     10 / 97  
good, this means the AoFE updater can be posted here.

Proud owner of Splash Splash XLIV: Leave it there for someone to find, Which is on record for being the fastest thread to reach 2500 posts - which was completed in 28 hours and 17 minutes, from start to finish!
Yeah, the republican party is pretty much one big schizophrenic ball of contradictions nowadays. - Ax_man1
double post for milestone, then relentlessly bash on the community for the hell of it... stay classy thymole. - Lurker
posted 10-04-12 03:05 PM CT (US)     11 / 97  
@uniqueUnitLine: The unit line of the unique unit. The editing of unit lines has not been fully discovered.
@uniqueUnitUpgrade: The research that upgrades the unique unit to elite status.
@uniqueResearch: The unique research of a civilization.
Are any of these the 'tech tree' tech or the 'team bonus' tech for the civ? I assume elite unit upgrade and a civs unique tech can be made like a regular tech and work fine, but the team bonus seems to be hard coded, perhaps the tech tree as well.
posted 10-04-12 03:15 PM CT (US)     12 / 97  
They are not hardcoded, you just have to use AGE 2 and click on the civilizations tab. From there you can change the techs and bonuses available to each civ, as well as the team bonus for each civ.
posted 10-04-12 05:55 PM CT (US)     13 / 97  
Oh, my bad. Thanks for that.
posted 10-06-12 05:46 AM CT (US)     14 / 97  
This article is in the clear. As is all future discussion of the UserPatch.
Does this mean the UserPatch can now be used and linked to here, or just that it can be discussed?

Kor | The Age of Chivalry is upon us!
Wellent ich gugk, so hindert mich / köstlicher ziere sinder,
Der ich e pflag, da für ich sich / Neur kelber, gaiss, böck, rinder,
Und knospot leut, swarz, hässeleich, / Vast rüssig gen dem winder;
Die geben müt als sackwein vich. / Vor angst slach ich mein kinder
Offt hin hinder.
posted 10-06-12 06:04 AM CT (US)     15 / 97  
I don't see a problem with linking or using but until I have confirmation (hopefully within twenty-four hours), it is probably best to stick simply with discussing.

[This message has been edited by Felix36 (edited 10-06-2012 @ 06:04 AM).]

posted 10-06-12 02:29 PM CT (US)     16 / 97  
Does this mean the UserPatch can now be used and linked to here, or just that it can be discussed?
It is fine to link. However, the UserPatch is still in an unfinished stage. It should be completely usable and hopefully bug free, but if someone downloads it, their version will probably become obsolete within a week when a new version is released. Also, any features they may use might end up being altered, or (more likely) those designing the patch will come up with an easier way to accomplish the same task, making their method possibly obsolete as well. Making such a note next to the link would be advisable. Once it's officially released, then there should be no restrictions. In fact, I'm pretty sure the AoKH will have a link to it on the front page.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob
posted 10-06-12 03:26 PM CT (US)     17 / 97  
AoKH will have a link to it on the front page.
Excellent! *rubs hands together*

I love front page updates!
posted 10-27-12 02:18 PM CT (US)     18 / 97  
I noticed this article said something about graphics editing with Turtle Pack, which makes me think you mod without ModPack studio. I can't get ModPack Studio on my computer, so I would be really interrested in how you do that. Thanks!

posted 10-28-12 05:39 AM CT (US)     19 / 97  
Hey there, crbenne!

We don't actually have an article on Turtle Pack just yet but hopefully we'll get one into our University soon. In the meantime, you may want to ask any modding questions like this over in the SD&M board.
posted 11-10-12 04:00 AM CT (US)     20 / 97  
I have two questions.
I have created my new civilization. It works well but:
what I need to do to can select it when I begin a new game? Because I can just play with it by random case. In the civilization selections, there is a blank choice that I can select.
Second question:
I Have created the unique unit and unique research. What I need to do for the computer creates by its own my unique unit? PLaying with this civilization, I can create or research but if the computer is playing with it, it doesn't work. To make it work, I have for example to tell that the unique unit is a cataphract and in the bonus civilization tell that the cataphract is automatically upgraded in the unit I created. This way, it works, I see that the computer creates my unit but there is another problem obviously. As the AI doesn't know the unit, it creates it unlimited.
Thanks for your help and sorry for my mistakes in english
posted 11-10-12 08:30 AM CT (US)     21 / 97  
what I need to do to can select it when I begin a new game? Because I can just play with it by random case. In the civilization selections, there is a blank choice that I can select.
You need to edit the language_x1.dll after entry 20150 (it should be the first blank entry after Koreans). Edit this entry to be your civ's name.
posted 11-11-12 10:13 PM CT (US)     22 / 97  
I should have posted this much earlier, but one of the developers of the Userpatch wanted to correct some of the information in this thread.

This link gives a lot of information about how the xml files work with the patch.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob
posted 12-02-12 12:29 PM CT (US)     23 / 97  
How do you define the UI for a new civilization? And what needs to be defined at all?

Edit: Another problem: How can I add more civ descriptions in the language.dll? They seem to have to be in order of the civ IDs, but there is only very limited space left in that part of the .dll so I am stuck with one (named) civilization.

[This message has been edited by John the Late (edited 12-02-2012 @ 01:57 PM).]

posted 12-02-12 10:01 PM CT (US)     24 / 97  
I would guess editing the interface.drs file is what would allow you to change the UI for each civ. I don't think you can do that through the methods shown in this thread.

I haven't done enough language file editing with the Userpatch to answer your second question.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob
posted 12-03-12 08:51 AM CT (US)     25 / 97  
I found a solution to the .dll problem: I'll just replicate all civ strings and set a new id to start reading the strings... I hope it'll work.

The interfac.drs is still a big mystery to me, though.
posted 01-21-13 06:39 PM CT (US)     26 / 97  
Hello everyone, I managed to create a new civilization by following these simple instructions, but there is a small problem ...

when I start the game with the new civilization (the 19th) the game crush, and then add this new civilization for me is useless.

Can someone help me?

posted 01-22-13 04:04 AM CT (US)     27 / 97  
I am not very well versed on these issues, but if LmScar13 doesn't see this, I can e-mail him and ask him to have a look at this, if he'd be willing (and if you'd like me to do so).
posted 01-22-13 05:02 AM CT (US)     28 / 97  
Yes, please! do me a pleasure!
posted 01-24-13 12:51 PM CT (US)     29 / 97  
I've sent the e-mail. Sorry for the delay.
posted 01-24-13 05:10 PM CT (US)     30 / 97  
don't worry!
posted 01-27-13 09:56 PM CT (US)     31 / 97  
How do you assign an In Game Interface(Themed Sidebars) to the 19th Civ? Even if it involves copying/cloning an existing one

anything to do with?

<civilizations langId="10230" descId="20150" aiNameOffset="140" uiBaseId="51100" uiStride="20" uiOffset="0"> ??
Please Help

[This message has been edited by AnimalMan (edited 01-27-2013 @ 09:58 PM).]

posted 01-28-13 06:17 AM CT (US)     32 / 97  
civilizations langId="10230" descId="20150" aiNameOffset="140" uiBaseId="51100" uiStride="20" uiOffset="0"
where did you get this string?
However, for the interface you have to change "uiBaseId=51100".

Help! Help me please! I'm desperate!

I've been trying for days to add a new civilization but it's all useless!!!!!!!!!!! Help me please!

[This message has been edited by AFFA the cleric (edited 01-28-2013 @ 08:55 AM).]

posted 01-28-13 10:01 AM CT (US)     33 / 97  
@AFFA Make sure your XML file doesn't have missing close tags or something. You can check its integrity by opening it with Firefox. If there is a problem, Firefox will use red text and tell you the exact line in the file that has the error.

Also, check that your data files aren't corrupted by running AoE2 non-UserPatch. (You should have both EXEs). If it crashes as well, then you could be in big trouble.

Other than that, I really can't help you very much. Make sure you do have UserPatch installed. I only tried this once, and it worked, so I don't have that much experience.

I'll probably need to see your XML file to deduce the problem.

@Felix I edited the article to update one thing (the @game tag). I also added a note at the bottom.
posted 01-28-13 10:59 AM CT (US)     34 / 97  
First of all, nice to meet you Lmscar13, however it is the same if I open the XML file with Internet Explorer 8 instead of firefox? because if I open internet explorer 8 with all the strings are written in red ... but I tried in every way ,I've added the interfaces to civilization 19 in all of the 3 display setting, I added a description in the civilizations tech tree for civilization 19, but still nothing, the game continues to crash...

[This message has been edited by AFFA the cleric (edited 01-28-2013 @ 11:18 AM).]

posted 01-28-13 05:06 PM CT (US)     35 / 97  
No, it's not the same if you open it in IE8. IE does NOT detect incorrect syntax in XML files.

What do you mean when you say you
added a description in the civilizations tech tree for civilization 19

Anyway, it would be best if you could just copy-paste you XML file into your next reply so that I can see it.
posted 01-28-13 05:17 PM CT (US)     36 / 97  
What do you mean when you say you
added a description in the civilizations tech tree for civilization 19
When you're playing if you press the F2 button appear the technology thech tree and in the left side of the screen appears the civilization informations and bonuses, that!

Now give me your e-mail address and i'll send you my XML file!

[This message has been edited by AFFA the cleric (edited 01-28-2013 @ 05:20 PM).]

posted 01-28-13 05:27 PM CT (US)     37 / 97  
Did you edit the tech tree data in A.G.E.? Because if you did, 90% chance that's the problem.

My email is now public, look at my profile to find it.
posted 01-29-13 05:41 AM CT (US)     38 / 97  
No, i haven't modifier the tech tree with AGE 2, i've only modifier the informations and bonuses on the left side of the screen with resource hacker!

However check your mail box! i've send you my xml file!
posted 01-29-13 07:47 AM CT (US)     39 / 97  
Try changing the The Conquerors to something else, like AFFA's expansion. Also, try setting the @uistride back to 2. But it doesn't seem that the XML file is the problem.

Have you added the Inca civ in the data files with AGE 2? If you have, and the suggestions above don't fix it, then you'll probably have to reinstall UserPatch.
posted 01-29-13 08:03 AM CT (US)     40 / 97  
I did everything right, but I have a doubt ... to make it work I have to select all the check boxes of options before the userpatch installation?
because I select only the first box and not the all others!
could this be the problem?
posted 01-29-13 08:16 AM CT (US)     41 / 97  
No, you shouldn't have to check any of the other boxes. If you've done everything I suggested and it still doesn't work, the only other thing you can do is replace your modified data files with your backups and start data editing again.
posted 01-29-13 08:53 AM CT (US)     42 / 97  
the only other thing you can do is replace your modified data files with your backups and start data editing again.
In wich sense? I don't understand? wich backup file? I want a tutorial step by step on how to add a new completely an playable civilization to the beginning, just after i've reinstalled the game! please
posted 01-29-13 11:33 AM CT (US)     43 / 97  
Before you make a modpack, you should always make backups of the original game data files so that you don't have to reinstall the game every time your modpack is messed up. To do this, find the data files (empires2.dat, empires2_x1.dat, and empires2_x1_p1.dat) and language files (language.dll, language_x1.dll, and language_x1_p1.dll), and copy and paste them to a different location. I usually create a folder within my Data folder called "Backup" and place those 6 files in that folder. You can find the data files in your Age of Empires II Data folder, and you can find the language files in the main Age of Empires II folder. Do this before you install the userpatch.

If your modpack ever gets messed up, you can get the files from the Backup folder and copy and paste them over your corrupted modpack data files. This way you can start over without reinstalling. You can also create backups of your modpack files as you work. Create another folder for your Modpack backups and periodically copy and paste your modpack files into that folder. That way, not all of your work is lost.

I haven't tried to add new civs, so someone else should take it from here.

EDIT: It's also possible that some other files should be placed in the backup folder.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob

[This message has been edited by Leif Ericson (edited 01-29-2013 @ 11:37 AM).]

posted 01-29-13 11:54 AM CT (US)     44 / 97  
Thank you Leif Ericson! but you are yet another person telling me something I already know and that I have already done!

I do not know what to do! I seriously need to add a new civilization but I can not! I did everything, all that I have told people I talked to on the forum but still nothing! it's useless!
posted 01-29-13 04:52 PM CT (US)     45 / 97  
Okay, if AoE2:TC no longer runs correctly but rather crashes every time, here's what to do:

If you have backups:
1) Replace all of your modded files with the backups, specifically empires2.dat, empires2_x1.dat, empires2_x1_p1.dat, language.dll, language_x1.dll, language_x1_p1.dll Then see if your AoE2 runs.

2) If it still doesn't run, replace age2_x1.exe with its backup.
3) Then re-install UserPatch and see if it runs.
4) If it doesn't, go to the "do not have backups" section.

If you do NOT have backups:
1) Re-install AoE2:TC.
2) Back up empires2.dat, empires2_x1.dat, empires2_x1_p1.dat, language.dll, language_x1.dll, language_x1_p1.dll, age2_x1.exe
3) Install UserPatch.

Once you get it to run:
1) Make sure you have backups.
2) Make your XML file (per this article).
3) With AGE 2, add a civ in the civs tab by copying another civ and pasting it.
4) Test to see if it crashes.
5) If it doesn't crash, continue modding, and test every couple of changes.

Note: The key is to make a few changes at a time, and test to see if everything runs. This way you can pinpoint errors much more easily.

[This message has been edited by LmScar13 (edited 01-29-2013 @ 04:55 PM).]

posted 01-29-13 05:30 PM CT (US)     46 / 97  
I thank you so much for your help, and I thank everyone else who helped me, but it's useless! Everything that you told me so far I've done an infinite number of times, always with the same result ... the game crush!the game crush!the game crush!

I'll never have the nineteenth civilization!
posted 01-29-13 07:21 PM CT (US)     47 / 97  
Okay AFFA, if you still want to get this to work, REINSTALL both Age of Empires 2: The Age of Kings and Age of Empires II: The Conquerors Expansion. EDIT: Download and install the Conquerors C patch.

1) Does it run after you do that?

Then, download the newest version of UserPatch and install it.

2) Does it run after this step?

Finally, modify the XML file in the Games folder to include your new civ, and add the civ in the data and language files.

3) Does it run now?

Answer each question in order.

IMPORTANT: reinstalling both AoK and AoC will nullify any modding and patching ever done. If you ask me, it's not worth it.

[This message has been edited by LmScar13 (edited 01-29-2013 @ 07:39 PM).]

posted 01-30-13 07:45 AM CT (US)     48 / 97  
Ehm,I guess that you will begin to hate me, but I ask you a more detailed explanation ...
now I say to you all things that I have, and you tell me in that exact order to use all of these things!

1. i've installed the both games cds games are in english language,but i've the original italian language files to replace them,can i replace them immediately after the installation?

3.i've the age2_x1 crack,just my cds games are not original,can i crack the game immediately after the installation?

4.i've the italian c patch installer

5.i've the c patch rack

6.the name of my userpatch is "UserPatch.20130116-154134"

7.i've the age2_x1.xml file(in wich mode can i modifier it for add the inca civilization?)

8.when I add the "games" folder, after which step?

9.I've resource hacker for edit the name of the civilization like this:

10244, "Spagnoli"
10245, "Aztechi"
10246, "Maya"
10247, "Unni"
10248, "Coreani"
10249, "Incas"

It's right?after wich step i modifier this string?

10.i've advanced GeniEd 2 for add new civilization,how to do it, because I've copied the same buildigs set of the Aztecs for the incas(number 5), but later, when I go to play the Incas did not have the same buildings set of the Aztecs, but they've the same buildings set of the Britons,why?

11.i've create an interface.drs file with the same incas interface for the 19th civilization,after wich step i insert it?

can you explicate in wich order i can do this steps?

I'm sorry again for the annoyance and thank you a lot!

[This message has been edited by AFFA the cleric (edited 01-30-2013 @ 08:03 AM).]

posted 01-30-13 08:03 AM CT (US)     49 / 97  
1. Good

2. Good

3. NO.

4. Very Good. Install the C patch Italian.

5. If you have the CD, you don't need any crack, and they could be what are making it crash!!

6. Good. Extract and install UserPatch.

7. The age2_x1.xml file goes in the \Games folder in the directory in which AoE2 is installed. UserPatch should have created this folder.

8. See above

9. That is all fine.

10a. Make backups as described in my previous post.

10b. OK, in AGE 2, click the options menu and check Enable Forbidden Buttons. Then, go to the Civilizations tab. Click Add in the bottom left. Click on 15 - Aztecs (5) and the click Copy in the bottom left. Click on your new civ (19 - (0)). Then click Paste in the bottom left. The green Name box in the upper middle should say Aztecs. Change this to Incas. Click Save in the upper left.

11. Run AoE2. You should now have a civ identical to the Aztecs except in name. You'll have to modify their tech tree tech and team bonus tech after you see if what you just did works.

11b. It doesn't matter when you add the interface to the interfac.drs.

[This message has been edited by LmScar13 (edited 01-30-2013 @ 08:45 AM).]

posted 01-30-13 08:38 AM CT (US)     50 / 97  
"Enable Forbidden Buttons" is no longer necessary for adding civilizations.

Advanced Genie Editor
Follow coding here and here.
« Previous Page  1 2  Next Page »
Age of Kings Heaven » Forums » The University » Adding civilizations to AoE2 (Approved)
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Kings Heaven | HeavenGames