You must be logged in to post messages.
Please login or register

Mod Design and Discussion
Moderated by Sebastien, John the Late

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: Introducing Advanced Genie Editor 3 with Language DLL Editing
« Previous Page  1 ··· 10 ··· 18 19 20  Next Page »
posted 01-25-13 03:34 PM CT (US)   
Finally you can edit language files in the Advanced Genie Editor.
Unfortunately, the library is broken and too complex for me to fix.
You can edit language files directly from the boxes which show lines from them.
The changes are stored to the base language file and if expansion files have data, they'll be wiped out.
There is an option to store changes to the latest expansion.
It should be possible to use any line between 0 and 65535 or maybe even more?

Here you can download it:
http://aok.heavengames.com/blacksmith/showfile.php?fileid=11002

This was all possible with C library by Apre:
https://github.com/apreiml/pcrio

Advanced Genie Editor
Follow coding here and here.

[This message has been edited by Keisari Tapsa (edited 06-14-2018 @ 04:10 AM).]

Replies:
posted 11-07-18 04:00 PM CT (US)     666 / 698  
I work with The Forgotten Empires (the non-HD), this version doesn't appear in the program as an option, so I choose Conquerors as AoFE was made on Conquerors.

>>><<<

Kio ne mortigas vin unue, mortigas vin poste.

>>><<<
posted 01-12-19 10:55 AM CT (US)     667 / 698  
hello

I just found an issue in "Effects" tab in AGE3.

The UI doesn't allow to type values for "Attribute Modifier" (both set and add) for attribute 8 (Armor, same thing for attack), when using custom types (out of 0-12 range).

For example I am trying to use a custom armor class to implement a fully configurable conversion resistance in AOE/ROR (it is hardcoded, by default).
It works, however the limitation I just described prevents me from having technologies or tech trees (typically Macedonian) that set specific conversion resistances.

I think it's just a UI glitch, the correction probably consists in removing a small portion of code that is too restrictive and reverts back the value we enter in the text box.

Thank you.

[This message has been edited by chab (edited 01-12-2019 @ 02:18 PM).]

posted 06-26-19 12:53 PM CT (US)     668 / 698  
Does anybody know if there is any way to do the following?:

1. Make it so villagers deposit wood into the lumber camp so that the wood doesn't go to the player's global resources, but is actually held in the lumber camp, and if it's destroyed the wood is lost. Also make it so that wood can be removed from that lumber camp by villagers and transferred to another lumber camp or a TC.

2. Allow functionality for using garrisoned units for production. For instance, garrison a villager, and when you hit the "train spearman" button, it removes a garrisoned villager but costs no food.

I've struggled with Advanced Genie Editor to let me do these things for hours with no success. Is it impossible, or simply not possible with Advanced Genie Editor 3, or possible but I just don't know how?

[This message has been edited by Edgewulf (edited 06-26-2019 @ 12:54 PM).]

posted 06-27-19 02:44 AM CT (US)     669 / 698  
I'm not sure what you mean chab. It works fine for me. You can put numbers as type that are not in the dropdown too.

Edgewulf
1. Yes actually you can have reverse lumberjacks. Copy task 110, change target class to -1 and target unit to the dropsite then use negative work value. Then you have another unit that can gather wood from the dropsite and use town center as regular dropsite. There may be some logic hardcoded about this, but in theory it should be doable.

2. No.

Advanced Genie Editor
Follow coding here and here.
posted 06-27-19 10:18 AM CT (US)     670 / 698  
Keisari

Thank you! That's very helpful! I'll give that a shot.
posted 07-01-19 11:37 AM CT (US)     671 / 698  
I realized there is an additional condition to reproduce the issue.
It fails for "type" values 128-255.

So the whole set of conditions to reproduce the issue is :

- Command type = 0 or 4 (attribute modifier, set or +/-)
- Attribute = 8 (armor) or 9 (attack)
- Type=any value between 128 and 255, included (which includes "-1" if we're working with a signed value)

In this case, it is impossible to set "Amount" field to anything else than 0

Conversion resistance must be kept apart from "standard" attacks/defences, that's why I need to use the attack type "-1", and not 13/14/whatever (because mods may already use such values).
posted 07-02-19 02:20 PM CT (US)     672 / 698  
I see that now chab, fix coming way too late. If you have Steam account you can reach me much faster.

Advanced Genie Editor
Follow coding here and here.
posted 07-03-19 11:19 AM CT (US)     673 / 698  
Is there a way to assign Language strings to Resources so they appear in the editor, like techs will if they're named?

Proud Member of Black Forest Studios
Co-creator of Silent Evil - Voted Best Multiplayer Scenario of 2009
and The Seas of Egressa - Voted Best Multiplayer Scenario of 2010
posted 07-04-19 08:20 AM CT (US)     674 / 698  
Nvm/

[This message has been edited by Sebastien (edited 07-18-2019 @ 08:21 AM).]

posted 07-17-19 01:23 PM CT (US)     675 / 698  
I see you've already uploaded a corrected version regarding attribute modifiers issues with armor/attack, thank you so much.
I can now do some testing... And I found (once more) a bug in the game, "multiply attribute" is not implemented at all in AOE / ROR !
Fortunately I can fix this in my mod RockNRor.
posted 10-24-19 03:32 AM CT (US)     676 / 698  
How to build/train a tree from a villager nor a building? The game crashed when If I try to train a tree.
posted 10-29-19 12:21 PM CT (US)     677 / 698  
Why is except dark age,the feudal,castle and imperial age Town Center graphics aren't showing up in Advanced genie editor ?
posted 12-04-19 08:20 PM CT (US)     678 / 698  
I've started using AGE 3 for DE and have so many questions. Would this thread be the appropriate place to be asking? Or is there a comprehensive guide somewhere for AGE 3?
posted 12-12-19 01:39 PM CT (US)     679 / 698  
Good question Gaspar.
I've been using it for a few days, and then it showed an error message.
I put back in place a backup dat file and the app keeps crashing.
I've reinstalled the game, no change so far :

"Unhandled unknown exception; terminating the application."

Winter is coming.
posted 05-04-20 06:37 AM CT (US)     680 / 698  
How I create a new civilization in the Advanced Genie Editor, entirely beacause I want to create a mod called "The Fanned Expansion", so you can explain me it, or better public a guide on Youtube
posted 07-14-20 03:17 PM CT (US)     681 / 698  
I'm occasionally getting an error message when I changed some armour stats on certain units which says the following.
Attack counts of civs 16,15 differs from civ1
What does it mean?
posted 07-14-20 09:39 PM CT (US)     682 / 698  
Ideally you want to be changing armour and attack values of units for different civs via techs or in the civs tech tree as a civ bonus. Having different data between units within the same unit ID in some cases can cause issues.

[This message has been edited by Sebastien (edited 07-14-2020 @ 09:40 PM).]

posted 07-16-20 09:23 AM CT (US)     683 / 698  
Yeah, I suggest you to autoupgrade the units you want from the base unit ID, in this way the unit ID will be calculated the same, but the statistics can be changed at will.

Just a couples of things you must keep present in mind when you do this:

1. the new unit autoupgraded MUST have the same unit class of the original unit ID (for example upgrading an archer to another unit means that the new unit must be considered as archers by the AI, but then in the armor classes you can canghe it even to a infantry cavalry, building etc...

2. if the original unit (example the archer) has a single projectiles, then the autoupgraded unit became something like a chukonu, the new chukos will not shoot multiples arrows but just one, but this rule activates only on the already present on map archers, then, once you train new archer autoubgraded, all the new like-chuks unit sill be refreshed to get their fulli projectiles numbers

3. as well as berserkers hardcoded autoregen. can be passed throug via this method, just autoupgrade the berserker to whatever unit ID you want and it will get the autoregen. ability

hope this helps you Sir!

__________________________________________________________________________________________________________________________________________
MY GAME VERSION:

Age of Empires II The Conquerors 1.0 without any patches, just the ES release in August 24th 2000, proud to playing this game version!

[This message has been edited by AFFA the Cleric (edited 07-16-2020 @ 09:25 AM).]

posted 07-20-20 03:08 PM CT (US)     684 / 698  
Hello. AGE doesn't work for me: it does save changes but they don't work in the game. Tried both in AoE 1 original and Definitive Edition.
Did someone have this problem?
posted 07-21-20 06:25 AM CT (US)     685 / 698  
Can you give us some more specifics about the actual problem.

What's not working for you.
posted 07-21-20 08:45 AM CT (US)     686 / 698  
My changes don't work.
They are saved in files, (e.g berry bush food amount - 150 ->300) but change doesn't occur.
posted 08-01-20 08:48 AM CT (US)     687 / 698  
Hi Keisari, I have an issue, today, AGE has suddenly stopped to works and don't wont to open in any way... yesterday worked fine to me, but today, without changing any setting, AGE won't open the mod... I mean, If I try to open the conquerors it works fine, but if I try to open Rise of rajas simply freezes immediately after I click open and that forces me to switch off my laptop by removing the plug...

what happened to my AGE?!?!

thanks in advance and keep forth the job!

__________________________________________________________________________________________________________________________________________
MY GAME VERSION:

Age of Empires II The Conquerors 1.0 without any patches, just the ES release in August 24th 2000, proud to playing this game version!
posted 08-01-20 09:00 PM CT (US)     688 / 698  
They are saved in files, (e.g berry bush food amount - 150 ->300) but change doesn't occur.
Youre probably modifying the wrong file. For DE, modifying the original .dat is no longer possible. Youll have to create your own local mod.
mean, If I try to open the conquerors it works fine,
Double check all settings are correct, especially the game data type (conquerors, rajas, etc). Make sure you're not still loading the rajas data with conquerors mode.

If doesnt work, redownload AGE and try again.

[This message has been edited by Sebastien (edited 08-01-2020 @ 09:03 PM).]

posted 08-02-20 06:11 AM CT (US)     689 / 698  
Double check all settings are correct, especially the game data type (conquerors, rajas, etc). Make sure you're not still loading the rajas data with conquerors mode.
Already done, everythings fine, but still don't works
If doesnt work, redownload AGE and try again.
Done this too, doesn't work as well

__________________________________________________________________________________________________________________________________________
MY GAME VERSION:

Age of Empires II The Conquerors 1.0 without any patches, just the ES release in August 24th 2000, proud to playing this game version!
posted 09-01-20 11:34 PM CT (US)     690 / 698  
Bottom-left copy/paste is flawed and does not work as floating help indicated.
No matter whether "All civs" is not selected or not, no matter how top-right civilization checkboxes is selected, bottom-left copy/paste always overwrite _all_ civs.

There is no way to copy from unit-A.civX to unit-B.civY without destroying unit-B.civZ.
For example, if I want to copy unit-A(all civ) to unit-B(civ0 only).
A. Wipe-out unit-B (civ1+) -> copy/paste does not work. Because pasting causes civ1+ exist.
B. Copy/paste -> wipe-out unit-B (all civs) -> exist unit-B (civ0) does not work. Because wipe-out (all) -> exist (one) corrupts data (e.g. type).
C. The only way is copy/paste -> wipe-out unit-B (civ1+ one by one), which is rather tedious.

[This message has been edited by fllwr9141 (edited 09-01-2020 @ 11:44 PM).]

posted 12-13-20 10:34 AM CT (US)     691 / 698  
@tapsa, attack and armor attribute change only allows addition, and multiplication in percentage which rounds up (no decimals). is this a limitation for the game itself or genie?

range/LOS cost etc can have both add and subtract but only attack and armor can't.
posted 01-28-21 11:08 PM CT (US)     692 / 698  
Please I could use some help.

Please be patient, I am an old person lol.

I was wondering if I can use this tool to modify the colors of unit "dots" I see on the minimap (player colors).

I have trouble making out green and yellow with my old eyes.

If this is possible, please tell me step by step how to do it.

And I thank you very much for any help you can give.

I have already used it to make Ornlu the Wolf trainable from my TC, so my villies can have a watch dog around their town!
posted 01-30-21 01:56 AM CT (US)     693 / 698  
Hi Keisari, can I check if the AGE Editor still works for the current .dat file of the AOE2DE game with the latest update and the Lord of the West DLC?

Domus Dulcis Domus --- Home Sweet Home...ZzZzZzZzZ
posted 03-02-21 11:01 AM CT (US)     694 / 698  
I'm trying to edit The Forgotten Empires (the non-HD version) and constantly getting a memory error or AGE random freezes when selecting the techs menu. I've tried it on other computers with other OS-es and they all do the same.

Is it possbile to download an older version? I haven't found any of them on the internet. I'd prefer one from 6 years ago. I know that's old, but enough for what I would like to do. Plus I can't use this version cause the constant freezing.
posted 03-25-21 00:22 AM CT (US)     695 / 698  
I have a quick question. I have downloaded the latest version (Last update was march 22 2021). I am new to A.G.E. and have a few questions. I am trying to change the description of a unit, when I make a change it tells me to reload the file and check the box that says "Write language files". I do so, and then return to the unit and change the description. Once I click out of the description box the program freezes and crashes without saving my changes. I was able to change the "Language File Name" to 0 and it let me change the name of the unit to whatever was written in "Internal file name" however, if I change any of the other number boxes (Language file creation, hotkey, language file help, help converter, etc.) it removes the text. When I type in new text it doesn't immediately crash, but when I save my changes it crashes and doesn't save anything (As I have looked at it further I have found that this seams to happen any time I have the "write language files" box checked". I've been searching all over for an answer but can't find anything. Does anybody know how to change a units description for Age of Empires II DE in Advanced Genie Editor 2021?

*I actually found out how to do it. This link explains it

https://steamcommunity.com/sharedfiles/filedetails/?id=1112216819

But for DE you need to use the file path

C:\Program Files (x86)\Steam\steamapps\common\AoE2DE\resources\en\strings\key-value

instead of the one that they have there (it only works for DE)

*Another update

So, I thought I had it all figured out. In Genie editor it shows the correct text now because I made the changes in the key-value-modded-strings-utf8 file. However once I open the game it seams like it doesn't even try to read that file. When I have a string ID that the game doesn't already have built in it doesn't read it, and when I have one that is already in the game but I changed the text to it doesn't change to my new text.

I have other changes I have made in the mod that are not just string changes and they come through in the game when I test the mod. It's just this one thing that isn't working.

[This message has been edited by kurichesnut (edited 03-25-2021 @ 02:59 AM).]

posted 07-07-21 12:13 PM CT (US)     696 / 698  
It seems that latest patch Update 50292 is causing the AGE Editor to crash the moment the .dat file is selected and loaded in the editor. Any work arounds?

Domus Dulcis Domus --- Home Sweet Home...ZzZzZzZzZ
posted 08-13-21 09:56 PM CT (US)     697 / 698  
Hi Keisari! Was wondering if the crash for AGE Editor when opening the latest version of the AOE2DE dat file with the Dawn of the Dukes DLC has been fixed please? I want to add in the entries for additional units/buildings I added from AOE1DE and others

Domus Dulcis Domus --- Home Sweet Home...ZzZzZzZzZ
posted 08-25-21 02:17 PM CT (US)     698 / 698  
I try to edit the dat file in AoE2_DE. How I can allow shallows to be placed on elevation?

~Finished Projects~
5 Christmasmaps

~soon~
some Minimaps and other stuff
« Previous Page  1 ··· 10 ··· 18 19 20  Next Page »
Age of Kings Heaven » Forums » Mod Design and Discussion » Introducing Advanced Genie Editor 3 with Language DLL Editing
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Kings Heaven | HeavenGames