You must be logged in to post messages.
Please login or register

The University

Hop to:    
Topic Subject: Adding civilizations to AoE2 (Approved)
« Previous Page  1 2  Next Page »
posted 10-01-12 04:22 PM CT (US)   
This article has been approved and can now be read in The University -Felix36

This is all possible because of UserPatch by xOmicron, and you need the latest UserPatch for this to work.

Preliminary Steps

First, you need to download and install UserPatch. Then, go to the folder where AoE2:TC is installed. Create a folder called Games. When you unpacked UserPatch, a folder called Reference should have been created. Go into this folder. There should be a file called age2_x1.xml. Copy this file to your Games folder that you just created.

The XML File

Now edit (using any simple text editor) the age2_x1.xml that you just copied and pasted. It should look something like this:

<?xml version="1.0" encoding="utf-8"?>
<configuration game="age2_x1">
<name>Age of Empires II: The Conquerors Expansion 2</name>
<path>The Conquerors</path>
<civilizations langId="10230" descId="20150" aiNameOffset="140" uiBaseId="51100" uiStride="20" uiOffset="2">
<civilization id="0" name="gaia" soundFile="stream\random.mp3" scoutUnit="448" uniqueUnit="0" eliteUniqueUnit="0" uniqueUnitLine="0" uniqueUnitUpgrade="0" uniqueResearch="0" />
<civilization id="2" name="briton" soundFile="stream\british.mp3" scoutUnit="448" uniqueUnit="8" eliteUniqueUnit="530" uniqueUnitLine="-277" uniqueUnitUpgrade="360" uniqueResearch="3" />
<civilization id="6" name="frankish" soundFile="stream\french.mp3" scoutUnit="448" uniqueUnit="281" eliteUniqueUnit="531" uniqueUnitLine="-272" uniqueUnitUpgrade="363" uniqueResearch="83" />
<civilization id="7" name="gothic" soundFile="stream\goth.mp3" scoutUnit="448" uniqueUnit="41" eliteUniqueUnit="555" uniqueUnitLine="-279" uniqueUnitUpgrade="365" uniqueResearch="16" />
<civilization id="16" name="teutonic" soundFile="stream\teuton.mp3" scoutUnit="448" uniqueUnit="25" eliteUniqueUnit="554" uniqueUnitLine="-273" uniqueUnitUpgrade="364" uniqueResearch="11" />
<civilization id="9" name="japanese" soundFile="stream\japanese.mp3" scoutUnit="448" uniqueUnit="291" eliteUniqueUnit="560" uniqueUnitLine="-274" uniqueUnitUpgrade="366" uniqueResearch="59" />
<civilization id="5" name="chinese" soundFile="stream\chinese.mp3" scoutUnit="448" uniqueUnit="73" eliteUniqueUnit="559" uniqueUnitLine="-280" uniqueUnitUpgrade="362" uniqueResearch="52" />
<civilization id="3" name="byzantine" soundFile="stream\byzantin.mp3" scoutUnit="448" uniqueUnit="40" eliteUniqueUnit="553" uniqueUnitLine="-281" uniqueUnitUpgrade="361" uniqueResearch="61" />
<civilization id="13" name="persian" soundFile="stream\persian.mp3" scoutUnit="448" uniqueUnit="239" eliteUniqueUnit="558" uniqueUnitLine="-271" uniqueUnitUpgrade="367" uniqueResearch="7" />
<civilization id="14" name="saracen" soundFile="stream\saracen.mp3" scoutUnit="448" uniqueUnit="282" eliteUniqueUnit="556" uniqueUnitLine="-276" uniqueUnitUpgrade="368" uniqueResearch="9" />
<civilization id="17" name="turkish" soundFile="stream\turk.mp3" scoutUnit="448" uniqueUnit="46" eliteUniqueUnit="557" uniqueUnitLine="-278" uniqueUnitUpgrade="369" uniqueResearch="10" />
<civilization id="18" name="viking" soundFile="stream\viking.mp3" scoutUnit="448" uniqueUnit="692" eliteUniqueUnit="694" uniqueUnitLine="-282" uniqueUnitUpgrade="398" uniqueResearch="49" />
<civilization id="12" name="mongol" soundFile="stream\mongol.mp3" scoutUnit="448" uniqueUnit="11" eliteUniqueUnit="561" uniqueUnitLine="-275" uniqueUnitUpgrade="371" uniqueResearch="6" />
<civilization id="4" name="celtic" soundFile="stream\celt.mp3" scoutUnit="448" uniqueUnit="232" eliteUniqueUnit="534" uniqueUnitLine="-269" uniqueUnitUpgrade="370" uniqueResearch="5" />
<civilization id="15" name="spanish" soundFile="stream\spanish.mp3" scoutUnit="448" uniqueUnit="771" eliteUniqueUnit="773" uniqueUnitLine="-264" uniqueUnitUpgrade="60" uniqueResearch="440" />
<civilization id="1" name="aztec" soundFile="stream\aztecs.mp3" scoutUnit="751" uniqueUnit="725" eliteUniqueUnit="726" uniqueUnitLine="-268" uniqueUnitUpgrade="432" uniqueResearch="24" />
<civilization id="11" name="mayan" soundFile="stream\mayans.mp3" scoutUnit="751" uniqueUnit="763" eliteUniqueUnit="765" uniqueUnitLine="-266" uniqueUnitUpgrade="27" uniqueResearch="4" />
<civilization id="8" name="hun" soundFile="stream\huns.mp3" scoutUnit="448" uniqueUnit="755" eliteUniqueUnit="757" uniqueUnitLine="-265" uniqueUnitUpgrade="2" uniqueResearch="21" />
<civilization id="10" name="korean" soundFile="stream\koreans.mp3" scoutUnit="448" uniqueUnit="827" eliteUniqueUnit="829" uniqueUnitLine="-270" uniqueUnitUpgrade="450" uniqueResearch="445" />

The Tags

<configuration>: The @game attribute specifies the game ID. The AIs use this "#if-defined GAME-@game" to load certain effects. Only useful if you want an AI to be used for more than one expansion.
<name>: Changing this is not known to do anything.
<path>: Specifies the folder within the Games folder where future saved and recorded games, scenarios, random map scripts, and AI scripts should be stored. A folder corresponding to this tag's value will be created when you start the game.
<civilizations>: @langId specifies the language_x1.dll name of the first civilization. @descId specifies the first language_x1.dll civilization description. @aiNameOffset has to do with the AI character names for civilizations. @uiBaseId specifies the first civilization UI slp in interfac.drs. @uiStride specifies the total number of civ UIs. This should be equal to the total number of civilizations. @uiOffset specifies the gap between the last UI of one resolution and the first UI of the next largest resolution.

Adding Civilizations

Finally! The <civilization> tag denotes a civilization. Add another of these tags to the list, and you've added a civilization. Now, lets get down to the attributes:

@id: The id number of a civilization. This number specifies the order of the UIs slps, and it is important for the data and language files. Each civ should have its own unique id. Your first new civ should have an id of 19.
@name: The internal name of a civilization.
@soundFile: The sound file that plays when a civilization is picked in a random map game.
@scoutUnit: The starting scout unit id (from the data files) of a civilization. Scout Cavalry is #448.
@uniqueUnit: The id number of the unique unit of a civilization.
@eliteUniqueUnit: The id number of the elite unique unit of a civilization.
@uniqueUnitLine: The unit line of the unique unit. The editing of unit lines has not been fully discovered.
@uniqueUnitUpgrade: The research that upgrades the unique unit to elite status.
@uniqueResearch: The unique research of a civilization.

Once you've added and edited all the <civilization> lines you want, save the xml file and start the game. Your new civilizations will be automatically added to the data file and will automatically appear in game.

Not Done Yet

I guess you could technically be done now. But, unless you want your new civs to be awful, you need to do more. Use Advanced Genie Editor 2 for data editing, Turtle Pack for graphics, and XN Resource Editor for language dll editing. With that, you're set!

P.S.: This article is correct as far as I know. However, this was all deduced by trial and error before UserPatch came with a readme that explains adding civs. Now that UserPatch does have such a readme, it makes this tutorial somewhat outdated. Scripter64 and Cysion know much more about this than I do.

[This message has been edited by LmScar13 (edited 01-28-2013 @ 10:05 AM).]

posted 01-30-13 08:42 AM CT (US)     51 / 97  
Proof that I really haven't done this in a while. I probably should update my AGE.
posted 01-30-13 08:43 AM CT (US)     52 / 97  
11b. It doesn't matter when you add the interface to the interfac.drs.
then i add the interface to the last, before I start the game, okay?
3. NO.
5. If you have the CD, you don't need any crack, and they could be what are making it crash!!
if I do not force to insert the crack will not let me play, even if the CD is inserted ... and I have 2 different crack, one before the c patch installation and one for after the c patch installation... what do I do?
10b. OK, in AGE 2, click the options menu and check Enable Forbidden Buttons. Then, go to the Civilizations tab. Click Add in the bottom left. Click on 15 - Aztecs (5) and the click Copy in the bottom left. Click on your new civ (19 - (0)). Then click Paste in the bottom left. The green Name box in the upper middle should say Aztecs. Change this to Incas. Click Save in the upper left.
this is the same thing that I've always done ... For example, after creating the Inca civilization on the basis of the Aztec civilization, their building set is the same(number 5), in fact, if I then go in the units section and control the graphics of an incas building and an Aztecs building ,the graphic is the same , however, if i start the game,the incas building is equal to the Britons buildings...
posted 01-30-13 08:47 AM CT (US)     53 / 97  
Well, like I said, it's probably due to the cracks, which I'm not sure HG allows us to discuss.
posted 01-30-13 08:49 AM CT (US)     54 / 97  
which I'm not sure HG allows us to discuss.
What do you mean?
posted 01-30-13 08:59 AM CT (US)     55 / 97  
You can get banned.

Advanced Genie Editor
Follow coding here and here.
posted 01-30-13 09:00 AM CT (US)     56 / 97  
Sorry,but why?
posted 01-30-13 10:00 AM CT (US)     57 / 97  
Maybe cause they're illegal??
posted 01-30-13 10:35 AM CT (US)     58 / 97  
sorry I have now solved the problem of crack ... Now the game works without crack
posted 01-30-13 01:22 PM CT (US)     59 / 97  
Just to reiterate here, HG has a zero-tolerance policy on no-cd cracks. Please don't mention them again.
posted 01-30-13 02:03 PM CT (US)     60 / 97  
Agree, will not happen again!
posted 01-30-13 03:35 PM CT (US)     61 / 97  
I don't want unnecessary cross-posting, but here's a video I made to show (how) it actually works. Maybe someone will find it helpful.
posted 01-30-13 03:55 PM CT (US)     62 / 97  
I know that now you all want to kill me... but what i see in this video, I did an infinite number of times in the same way! but still crush! sorry I do not speak more in this topic...
posted 01-30-13 07:36 PM CT (US)     63 / 97  
Cracked versions of the game can cause weird crashes, especially when people try to mod with them. That's another reason not to use a crack. Have you tried doing this with a version of the game installed from a purchased CD?

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob
posted 01-31-13 06:14 AM CT (US)     64 / 97  
Have you tried doing this with a version of the game installed from a purchased CD?! I've only the non-original CDs...
posted 01-31-13 07:03 AM CT (US)     65 / 97  
If you don't have an original copy of the game, then we can't help you. If you want any help from us, you're going to have to purchase a legal copy.
posted 02-02-13 07:36 AM CT (US)     66 / 97  
ok so im wondering if i can get some help with this custom civ stuff
ive got the civ up to where i can play it in game
works fine still needs edits like unique units but that will come in time=p

but the interface is all messed up

reading some posts here there were hints that this requires interface drs edits?

if so how exactly do i do this

thank you
posted 05-28-13 10:39 AM CT (US)     67 / 97  
I got the same problem. need to change UI. I found the UI files in interface.drs but I need to add new slp, then link it to my new civ. I have no idea how to do this, any help please? thanks
posted 05-28-13 01:11 PM CT (US)     68 / 97  
If you don't have an original copy of the game, then we can't help you. If you want any help from us, you're going to have to purchase a legal copy.
Just tell him to download 1.0e patch
posted 05-28-13 04:30 PM CT (US)     69 / 97  
Just tell him to download 1.0e patch
Don't worry, i managed to add a new civ, but there is a greather problem... my new civ, during a game, don't train any military units... so is an useless civ...
posted 05-28-13 09:29 PM CT (US)     70 / 97  
Well, your new civ will need a new AI to train the new units. Most AIs will have different sections in the code for each civilization. If there isn't a section for your new civ, then the AI won't work properly.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob
posted 05-29-13 12:40 PM CT (US)     71 / 97  
I eventually understood how worked the aiNameOffset, and thus know how to display new leaders names for a new civilization!

The number that appears next to aiNameOffset is a gap between the last string of Age of Kings names & the first string of Conquerors names OR, as Forgotten Empires did, another string. Just remember that the last AOK string isn't the one containing Ethelred the Unready (the last name displayed for AOK civs), but the last you COULD write. So, although Ethelred is displayed at string 4656, it is however from 4660 that you must calculate the gap, since it's the maximum possible (id est, you can add 4 names max. for the Celts if you wish to).

So by default, the gap is between 4660 and 4800, the string displaying the number of names used by the Spanish civ. 4800-4660 = 140, the default number for aiNameOffset. Problem is, there is few space left after the Koreans, the last civ displayed. So if you wish to add new names for your new civs, you have two solutions:

-adding a new resource folder after the one containing the Korean names, so that you may continue the initial list of strings
-moving all the Conquerors civilizations names to another resource folder (so other strings) in order to get more spaces for your new civs.

I'd advise the 2nd one (that FE used) because it's true you won't have enough space to add new names after the Korean ones, and also because Pebble and Resource Hacker don't seem to be able to add completely new resource folders (at least, me I didn't manage to).

Thanks to the FE team for that, not because I asked them, but because I checked their .dll and finally understood how they did: bravo!

I think it's worth adding that in the main post, so hopefully LmScar is back soon...

"Vous vous rendez compte, la France est le seul pays au monde où l'on recycle toujours les mêmes hommes politiques, même lorsqu'ils ont échoué !" Nicolas Dupont-Aignan

posted 08-22-13 01:55 AM CT (US)     72 / 97  
Sorry, my English is bad. I would like your help, please. I already I have created my basic civilization, is the copy of the Aztecs but changed features and technologies. The problem is this: I have created a "uniqueUnit" "copied from "Jaguar Warrior", the problem is that on the "units", in the section "GRAPHICS", I have added the movements(SLP Files) of my new unit (new unit entered in the DRS Editor, SLP files). The problem is that when you start the game, the image of my new unit is the Jaguar Warrior and not the new one that was created(SLP in DRS Editor).

Help, please. Gracias.
posted 12-24-13 05:16 AM CT (US)     73 / 97  
Is it possible to use this method to add new civs with AOK:HD and The Forgotten? What configuration settings and values would I need to alter in the xml?

[This message has been edited by Haast Uhr (edited 12-24-2013 @ 05:18 AM).]

posted 12-24-13 04:57 PM CT (US)     74 / 97  
No, because HD doesn't allow you to install Userpatch with it since the Userpatch edits the .exe file. This is only possible with the CD version.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob
posted 10-16-14 03:31 AM CT (US)     75 / 97  
Hey all, Greetings. I'm new to this forum, and seeking guides from all experts of this "Adding New Civilizations" topic.

I've followed the video tutorial by other members and successfully make the new civ I've made appears on the list of playable civ, but when I start the game, it crashes. Any suggestions? Also,I would very appreciate if there anyone who can compile all the good suggestions and advice of this topic into a complete step-by-step tutorial (written text or videos) so that a newbie like me can learn from it. thank you so much

[This message has been edited by ramuness_id (edited 10-16-2014 @ 03:32 AM).]

posted 03-29-15 04:13 PM CT (US)     76 / 97  
Do i Still need to install the userpatch if I am modding the Non-HD forgotten empires?

I added the lines to the Age of empires II -> Games -> Age2_x2.xml file that is pre existing with the Forgotten Empires Expansion but doesnt seem to show my new civ in the drop down list?
posted 03-29-15 09:00 PM CT (US)     77 / 97  
If you're not working with the Steam version, I think modifying the age2_x1.xml is what you want.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob
posted 03-29-15 10:44 PM CT (US)     78 / 97  
Its age2x2 for forgotten and yes i installed that patch and then modified it, and it worked XD thanks!
posted 11-14-15 01:28 AM CT (US)     79 / 97  
I remember a year ago I did this in 2 occasions, I edited the XML file and added my 24th civ (under the slavic one from AoFE which is the 23rd), named it "Romans", but when I entered the game, all I got was a second civ called "Aztecs" and when I started a random map with them, my resolution was all messed up.

Any idea why this happened?
posted 12-23-16 01:26 AM CT (US)     80 / 97  
I've done all of this stuff and it's worked, but how do I add my civ to my mod so I can play it online with others on Voobly? I tried adding the Games folder with the age2_x1.xml to the data zip folder that I upload, but it still didn't work because the age2_x1.xml file wasn't used when running the mod. Any ideas?
posted 02-18-17 05:59 PM CT (US)     81 / 97  
SOMEBODY REPLY! I have no idea how the 'vertical line number' in the Tech Trees section works. I'm trying to get the tech tree to show my new technologies but it probably has something to do with the vertical line numbers and I've just left them at 0 for the moment since there doesn't seem to be any pattern.
Also, the tech tree claims that my new civilization does not have access to Hussars when they are quite clearly enabled and I can upgrade it in-game. After I upgrade it the game then claims correctly that it is available, since if it was able to be researched it's obviously available.
posted 02-18-17 07:10 PM CT (US)     82 / 97  
Have you seen this article?: Link

Let me know if you have any further questions. I haven't personally worked with tech trees before.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob

[This message has been edited by Leif Ericson (edited 02-18-2017 @ 07:11 PM).]

posted 02-19-17 00:04 AM CT (US)     83 / 97  
OK I actually managed to figure all of that out myself before I saw that link. Thanks for that though, it confirms everything.
A problem I do have though is that I made a unique tech for my new civ, and it is researched at the Siege Workshop in the Castle Age rather than the Castle (I'm also gonna have an imp UT at the Castle tho), and I managed to get it to show there, however it also shows to be available for all civilizations, not just the one I added and the one that is exclusive to my civ. I sorta fixed this by disabling it in all of the other civs' tech trees so it appears crossed-out, but how do I make it so it only appears for my new civilization and not the others? I know it should be possible because the Goths have Anarchy which is thje only tech that appears in its certain spot, and no other civ shows that in their tech tree, only Goths. Maybe it's hard coded?
Also it still shows that Hussars are disabled even though they clearly aren't :P
posted 02-19-17 07:12 PM CT (US)     84 / 97  
As in many things with the tech tree, it's hardcoded. The castle is the only building that can display civ specific units/techs. All unit/tech that you make available for a civ in another building will show up in the tech tree for all other civs too.

Fluctuat nec mergitur.
posted 02-20-17 09:48 AM CT (US)     85 / 97  
That makes sense. Thanks for the explanation.
posted 02-24-17 11:56 AM CT (US)     86 / 97  
I have never found any help on certain things of my made-up civilization that I added to the game.
Firstly, the background graphics style of the civ is just a cyan/grey boring thing with no patterns or anything, and I have no idea how to change it, even just giving it the one that the Celts use or something.
Secondly, all of my shepherds turn female when they harvest from a sheep.
Thirdly, my foot soldiers and male villagers speak the same as in AoE1 but updated (these sounds were also used in the beta of AoE2 so they sound better quality than in AoE1), however my female villagers sound Japanese. And when I ask them to gather from a sheep, they make the Britons military unit attack speech sound.
Fourthly, the tech tree shows Hussars as being disabled even though the upgrade is most definitely available and there's nothing in the data files that would disable Hussar or have anything to do with it.
posted 02-25-17 10:03 AM CT (US)     87 / 97  
For the third one, check the sound IDs in AGE for the villagers for your new civ to see if they're loading the correct files. My guess is that they're loading a different sound file than they should be.

For the second one, double check in AGE to see that the male shepherd unit is supposed to use the male graphics rather than the female ones.

I don't know about the civ interface or the tech tree issue.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob
posted 02-26-17 11:35 AM CT (US)     88 / 97  
Thanks Leif Ericson, I had actually managed to solve all of these problems myself before I saw your post; EXCEPT the one that you don't know how to fix, with the UI and the Hussars being disabled.
check the sound IDs in AGE for the villagers for your new civ to see if they're loading the correct files. My guess is that they're loading a different sound file than they should be.
They are not using different sounds than they should be, because I haven't added sounds for them yet, so they just use the default sounds that AoE2 assigns for any civilization that doesn't have specific sounds. Therefore the Frontche male units use sounds that are really similar to the ones in the original Age of Empires but with higher quality and sounding quieter, since in the beta versions of AoE2 they were planning just to make the units from all civilizations all have the same sounds like how it was in AoE1. Then they decided to scrap that and give different sounds to every civ's units, and the original sounds were left being for Gaia and other new civilizations to use.
I actually heard these sounds first by using the Natural Wonders cheat on scenarios, and selecting Gaia units that needed to be captured, then tasking them to do stuff and hearing all of their sounds. It was super interesting, and finding out that my Frontche civilization also started using these sounds, and seeing a video of the beta version of AoE2 really opened my eyes to how it all works.
And originally they didn't have female villagers, so they must have not ever added original voices for those and only added them after every civ was given different voices. So the Japanese voices became the default for any civ without specific assigned sound files.
Sorry this became really long. lol.
posted 06-23-17 10:59 PM CT (US)     89 / 97  
If I use FE with conqc CD do I need the patch?
posted 06-24-17 11:19 PM CT (US)     90 / 97  
Do you mean the old Age of Forgotten Empires mod that was released before the expansion went on Steam? If so, I believe it comes with Userpatch already installed.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob
posted 06-26-17 06:36 PM CT (US)     91 / 97  
Ok, yes. I see that now. So I copy and pasted one of the civ lines but when I go into the game I don't see my civ in the list.
posted 06-29-17 00:50 AM CT (US)     92 / 97  
I haven't created a new civilization myself. If you placed your new .xml file correctly in the Age of Empires II/Games folder and no one answers your question soon, I'd suggest asking the question in the Mod Design forum.

~`o´~|\  Join the fresh and exciting AI Ladder for its fourth season!
´ `  |_\
       |    Learn the joy of AI scripting in my guide: The World of AI Scripting
 \        /
   .....Hinga Dinga Durgen! - SpongeBob
posted 07-02-17 03:04 PM CT (US)     93 / 97  
Did you also add your civ to the data and language files? Without a string value, new civs will show up as a blank line.

AoK: Realms
Adds Armenians, Balts, Bamars, Bohemians, Bulgars, Burgundians, Chimus, Dutch, Helvetians, Jurchens, Khmers, Malays, Mandinkas, Moors, Muisca, Tamils, Tufans, Turcomans, and Viets

Proteus and Genie Converter - AKX installers for modern times
posted 07-11-17 10:29 AM CT (US)     94 / 97  
Why when I pick civ the game stops working I am doing this on patch 1.4 is there a problem with that ?
posted 10-13-17 10:39 AM CT (US)     95 / 97  
It's also possible to remove existing civs right? I did it a long time ago but forgot how to. Anyone who can help me with this?

Edit: Nvm found it. Seems like putting it in comments wasn't the same as removing the lines.

[This message has been edited by Jan dc (edited 10-13-2017 @ 10:41 AM).]

posted 01-20-19 10:01 PM CT (US)     96 / 97
This maybe of use to some.
posted 11-20-20 08:30 AM CT (US)     97 / 97  
What configuration game name should i put to make the AI think it plays on DE?

I mean make the AI load

#load-if-defined DE-AVAILABLE


Is it possible, does it require exe editing?
« Previous Page  1 2  Next Page »
Age of Kings Heaven » Forums » The University » Adding civilizations to AoE2 (Approved)
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Kings Heaven | HeavenGames